RedSn0w 0.9.10b6 Released

RedSn0w 0.9.10b6

Almost 24 hours, after Apple announced and released iOS 5.1 to the public, the iPhone Dev-Team has already updated redsn0w to version 0.9.10b6 to support a TETHERED jailbreak for non-A5 device owners that are running iOS 5.1.

Old bootrom iPhone 3GS models will still have the untethered jailbreak. The owners of iPad 2 and iPhone 4S will not be able to jailbreak at iOS 5.1. There is no turning back now as they cannot downgrade back to iOS 5.0 or iOS 5.0.1 once Apple stops signing the iOS 5.0.1 firmware.

Redsn0w 0.9.10b6 still supports the untethered jailbreak for iOS 5.0 and iOS 5.0.1. Thus, there should not be any rush to update. In a recent blog post by the iPhone-Dev Team dubbed March Mayhem, the team is advising you (and other users like you) to avoid upgrading to iOS 5.1 completely until an untethered jailbreak can be created. If you consider a jailbreak as unimportant in comparison to being able to use iPhoto, delete photos from Photo Stream, and having an always existent camera slider on your lock screen, then you can update if you wish to.

Redsn0w 0.9.10b6 is a tethered jailbreak for non-A5 devices. That is why, you will be required to ‘boot tethered’ every time you attempt to turn on or reboot your iDevice after you have applied the tethered jailbreak. The iPhone Dev-Team is warning for those relying on an unlock that wants to install iOS 5.1 and perform the tethered jailbreak to make a custom .ISPW file with the NO_BB_* version of iOS 5.1 to restore to. They have said that ultrasn0w will be updated in the next couple of days to support it.

An iBooks fix does not exist in the iOS 5.1 tethered jailbreak. Thus, if you rely on iBooks for your purchased content, then this is another reason to stay away from iOS 5.1. A future version of redsn0w has been cited to contain a fix for iBooks. The full iPhone Dev-Team update below:

Originally Posted by iPhone Dev-Team

Update #1: First, please read and re-read the above warnings! With all of that in mind, we realize that some of you non-A5 jailbreakers are itching to get to 5.1, even though there seems to be no compelling new feature there. Because of geohot’s limera1n exploit, those with devices earlier than the iPad2 can test the 5.1 jailbreak waters if they really want to, using redsn0w 0.9.10b6. Here’s what you need to know:

* This is a *tethered* 5.1 jailbreak for non-A5 devices. You’ll need to use redsn0w to “Just Boot” your device every time it power cycles, otherwise jailbreak apps won’t work (neither will Safari).
* If you use ultrasn0w for your carrier unlock, be sure to use a custom IPSW to get to 5.1 first! Don’t ever restore to a stock Apple IPSW! Use redsn0w’s “Custom IPSW” button to create a NO_BB_* version of the 5.1 *IPSW and restore to that instead of the stock one. (That option is available only to 3GS and iPhone4-GSM owners.) ultrasn0w itself will be updated for 5.1 in the next few days (same baseband support, not 5.1’s baseband).
*If you’re lucky enough to have an old-bootrom 3GS, this jailbreak is actually untethered (redsn0w will figure that part out automatically).
*While we were at it, we added pod2g’s steaks4uce exploit to support MC models of the iPod touch 2G (whose last firmware was 4.2.1). So now redsn0w will auto-detect and jailbreak both MB and MC versions of that older device.
*iBooks won’t work until a future update of redsn0w

We are advising our readers using jailboken devices to stay away from iOS 5.1 until an untethered jailbreak is created.

Source: Modmyi

Written by

The author didnt add any Information to his profile yet