Ultrasn0w 1.2.5 Can Unlock iOS 5.0.1 On iPhone 3G, 3GS And 4

Ultrasn0w 1.2.5

An updated version of UltraSn0w has recently been released on Cydia. It seems to support the iPhone firmware, iOS 5.0.1.

Users who wish to unlock iOS 5.0.1 will need an unlockable baseband to utilize UltraSn0w. However, those who meet the requirements can now possible to unlock their iPhone 3G, iPhone 3GS and iPhone 4 while running iOS 5.0.1.

The requirements that are needed to utilize UltraSn0w 1.2.5 are as follows:

1. A jailbroken iOS device.

2. An unlockable baseband which includes two things as follows:
(i) iPhone 4: baseband 01.59.00
(ii) iPhone 3G/3GS: basebands 04.26.08 05.11.07 05.12.01 05.13.04 and 06.15.00

However, you need to remember that this version of UltraSn0w does not bring any new baseband compatibility to the table. It only supports the iPhone 3G, iPhone 3GS, and iPhone 4. At the moment, there is no iPhone 4S support, as there has been no public release of an iPhone 4S jailbreak yet. There are rumors saying that once the iPhone 4S jailbreak is released, UltraSn0w might be updated to help unlock the iPhone 4S.

Are you interested in updating your Ultrasn0w Ultrasn0w 1.2.5? Share your thoughts and opinion in the comments section.

Source: Modmyi

Written by

The author didnt add any Information to his profile yet